
Capítulo-7: Momentum 

1 Fundamentos de Momentum 

Momentum es un simulador electromagnético que calcula los parámetros S para circuitos 

planares. Nos proporciona una herramienta para predecir el comportamiento de circuitos de 

alta frecuencia, antenas, etc. 

Para la creación y simulación de diseños se suelen seguir estos pasos: 

• Elegir entre modo “momentum” o “momentum RF”: el modo de microondas se elige 

cuando queremos simulaciones de onda completa (incluyendo efectos radiantes). 

Usamos el modo RF para diseños geométricamente complejos, eléctricamente 

pequeños y no radiantes (es decir, cuando queremos ignorar radiaciones). 

• Crear un diseño físico. Hay tres formas: 

1. Convertir un esquemático en un layout. 

2. Dibujar el diseño usando layout. 

3. Importar un layout con otro formato. 

• Definir las características del sustrato: la definición incluye el número de capas en él, y 

la composición de cada una. 

• Resolver el sustrato: se calcula la función de Green que lo caracteriza para un rango de 

frecuencias. Estos cálculos se guardan, y se usan más tarde en el proceso de 

simulación. 

• Asignar puertos a la estructura. Además podemos asignarles sus características. 

• Añadimos una caja o guía de ondas: permiten especificar límites en el sustrato a lo 

largo del plano horizontal. Sin ellas, se considerarán dimensiones infinitas en dirección 

horizontal. 

• Generar la rejilla: con ella se discretiza el diseño en pequeñas células. 



• Simular el circuito: especificamos el rango de frecuencias a simular. Este proceso usa la 

función de Green del sustrato más el patrón de rejilla, calculando de esta manera la 

corriente en el diseño. 

• Crear componentes: para poder usar el diseño en el esquemático. 

• Ver resultados: los datos se guardan como parámetros S o como campos. 

• Optimización: ajusta el layout para mejorar el comportamiento del circuito. 

• Patrones de radiación: podemos representarlos una vez que conozcamos las corrientes 

que definen el diseño. 

1.1 Añadir un Puerto a un Diseño en la Ventana de Layout 

Para añadir un puerto en la ventana de layout vamos a seguir los siguientes pasos: 

• Determinar dónde queremos posicionar el puerto. Un puerto puede ser aplicado a: 

1. El pin de un componente: por ejemplo en la ventana de esquemático, el punto de 

conexión de un componente podría ser un puerto de una red de microondas. 

2. El borde de un componente u objeto, normalmente en su punto medio: usado en 

la mayoría de los casos cuando se diseña una estructura en “momentum”, donde 

lo que se tiene es un layout. 

3. En la superficie de un objeto: podría aplicarse en un caso similar al de antes, pero 

sobre la superficie de un layout. Un ejemplo podría ser el de una transición 

ortogonal. 

 

Ilustración 1: Detalle Tipo de Puertos 

• Identificar el nombre de la capa en la que se encuentra el componente o forma a la 

que se quiere aplicar el puerto. 

• Cuando seleccionas el componente “Port” (en el menú Component -> Port), se nos 

abre un cuadro de diálogo. El parámetro “layer = “  indica a qué capa se aplicará el 

puerto. 



• Posicionamos el ratón donde queremos colocar el puerto, y hacemos click. De esta 

manera, habremos añadido el puerto al circuito.  

• Cuando acabamos de añadir puertos, hacemos click en “OK” dentro del cuadro de 

diálogo, cerrando éste. 

1.2 Sustratos en Momentum 

Un sustrato es el medio sobre el que existe el circuito. La definición del sustrato te permite 

especificar propiedades como el número de capas en el sustrato, la constante dieléctrica, y el 

alto de cada una de las capas que compondrán el circuito. 

La definición de sustrato se constituye de las capas de sustrato (“Substrate Layers”), y las capas 

metálicas (“Metallization Layers”). Las capas de sustrato definen el medio dieléctrico, los 

planos de tierra, aire, entre otras capas materiales. Las capas de metalización son capas 

conductivas colocadas entre dos capas de sustrato. Mapeando las capas definidas en el layout 

a las capas de metalización, podemos posicionar las capas dibujadas en la ventana de layout. 

1.2.1 Aplicación de Vías 

Momentum crea una vía atravesando un objeto (lámina, cilindro, prisma) a través de una capa 

de sustrato mapeada como vía. Las vías son dibujadas como líneas o polígonos cerrados. 

 

Ilustración 2: Tipo de Vias 

Las vías son tratadas de las siguientes formas: 

• Son representadas como láminas infinitamente finas de metal. Si dibujamos un cilindro 

como vía, también es considerado como láminas de metal separadas que componen 

las paredes del cilindro. 

• Se asumen las vías abiertas, no cerradas, con corriente circulando por la lámina. 

• Una vía no puede coincidir con otra vía si cortan a través de la misma capa de sustrato 

y están en capas del layout diferentes. 

• Las vías pueden ser especificadas con pérdidas, pero se considera que tienen cero 

espesor. 



1.2.2 Modelos de Simulación de Vías 

Existen tres modelos de simulación de vías: 

• Modelo distribuido 2D: es el modelo por defecto. Se crea dividiendo la superficie con 

células rectangulares. Solo se modela la componente vertical de la corriente. 

 

 

Ilustración 3: Modelo Distribuido 2D 

• Modelo de parámetros concentrados: las vías se extraen de las estructuras y son 

reemplazadas por su modelo de parámetros concentrados. Se calculan 

automáticamente modelos de resistencias e inductancias en serie a partir de la 

geometría y los parámetros de los materiales. No se incluyen las inductancias mutuas. 

 

 

Ilustración 4: Modelo de Parámetros Concentrados 

 

• Modelo distribuido 3D: divide la superficie de la vía en células rectangulares. Se 

modelan tanto los componentes horizontales como los verticales de la corriente de las 

vías. Se incluye las autoinductancias , inductancias mutuas, y capacidades, en la 

simulación. 

 



 

Ilustración 5: Modelo Distribuido 3D 

 

 

 

 

 

 

 

 



2 Puertos en momentum 

Los puertos permiten que la energía fluya hacia dentro y hacia fuera del circuito. La energía se 

aplica al circuito como parte del proceso de simulación. Un circuito resuelto usando 

“momentum” debe tener, como mínimo, un puerto.  

Los puertos son definidos en un proceso de dos pasos: 

• Los puertos se añaden al circuito cuando se dibuja éste. 

• Especificamos el tipo de puerto más adecuado para la aplicación que se pretende. Esto 

facilitará el proceso de simulación. 

Existen cinco tipos de puertos: 

• Single (por defecto): el puerto es calibrado para eliminar desadaptaciones en la 

frontera del mismo. Este tipo de puertos en capas SLOT tienen polaridad. A menos que 

definamos el puerto como de otro tipo, será tratado como de tipo “single”. 

• Internal: el puerto no está calibrado. Se usa normalmente para realizar conexiones con 

elementos de parámetros concentrados, o para representar otras conexiones en el 

circuito. 

• Diferencial: dos puertos con polaridad opuesta. El par es simulado como un puerto 

tipo “single”. 

• Coplanar: dos puertos con polaridad opuesta. El par es simulado como un puerto tipo 

“single”. 

• Common mode: dos o más puertos excitados con el mismo potencial absoluto y de la 

misma polaridad. Los puertos son simulados como puertos “single”. 

• Ground reference: usa una tierra explícita para un puerto “single”, “internal”, o 

“common mode”. 

2.1 Herramienta “Port Editor” 

Una vez que el sustrato y las capas dieléctricas son definidas, se puede usar la herramienta 

“Port Editor” (Momentum -> Port Editor…) para cambiar las características de los puertos en 

una ventana de layout. Se puede editar el puerto de la misma forma que se hizo cuando se 

introdujo. 

 



3 Cajas y Guías de onda 

Cuando se especifica la definición del sustrato de un circuito (Momentum -> Substrate), se 

especifican solo las dimensiones verticales del sustrato y no las dimensiones horizontales. 

Dada esta definición, las capas de sustrato se extienden de todas formas hasta el infinito en la 

dirección horizontal. En muchos circuitos, esto no es relevante. Sin embargo, hay otros muchos 

casos en los que se quiere introducir límites horizontales. Para esos casos, podemos usar las 

cajas y las guías de onda. 

Una caja te permite establecer límites en las cuatro caras del sustrato, mientas que una guía 

de ondas, tan solo te lo permite establecer en dos de las cuatro caras. 

Más específicamente, para una caja, definimos cuatro planos perpendiculares de conductor 

perfecto, como límites horizontales del sustrato. Una caja tan solo puede ser usada cuando la 

capa superior, y fondo del sustrato están definidos como planos de tierra. De esta manera, 

cuatro paredes verticales, más la capa superior y el fondo como planos de tierra, resultan una 

caja. 

 

Ilustración 6: Ejemplo de Carcasa Metálica 

Una guía de ondas es similar, aunque en este caso solo se especifican dos paredes verticales. El 

sustrato estará limitado tan solo en las direcciones perpendiculares a estas paredes. En la 

dirección paralela a esas paredes, el sustrato se extiende hasta el infinito. La capa superior y el 

fondo seguirían estando definidos por sendos planos de tierra. 

 

Ilustración 7: Ejemplo de Guía de Ondas de Placas Paralelas 

3.1 Añadir una Caja al Diseño 

Añadir una caja a un circuito permite analizar los efectos de encerrar el circuito en una jaula de 

metal. La resonancia en la caja podría tener efectos significativos en los parámetros S en una 

banda pequeña centrada alrededor de la frecuencia de resonancia de la caja.  

Para añadir una caja se siguen los siguientes pasos: 



• Elegimos Momentum -> Box-Waveguide -> Add Box. 

• Insertamos una caja usando uno de los dos siguientes métodos: 

1. Posicionamos el ratón y hacemos click para definir la esquina de la caja. Movemos 

el ratón hasta la esquina diagonal, y hacemos click. 

2. Mediante la herramienta del menú Momentum, Insert -> Coordinate Entry. 

Al finalizar estos pasos, la caja queda dibujada en el layout. 

3.2 Añadir una Guía de Ondas al Diseño 

Para añadir una guía de ondas al diseño procedemos del siguiente modo: 

• Elegimos Momentum -> Box-Waveguide -> Add Waveguide. 

• Seleccionamos la dirección de la guía de ondas. Para insertar la guía de ondas paralelas 

al eje X, hacemos click en X-axis. Para insertarla en el eje Y, hacemos click en Y-axis. 

• Insertamos la guía de ondas usando cualquiera de los dos métodos explicados en el 

punto anterior para la introducción de una caja. 



4 Mallado 

Una malla puede estar formada por un patrón de triángulos o rectángulos, formando cada uno 

de ellos una célula. Este patrón de células está basado en la geometría del circuito, y 

opcionalmente, en parámetros definidos por el usuario, por lo que cada circuito tendrá una 

única malla calculada para él. 

La malla se aplica al circuito para calcular la corriente en cada una de las células, e identificar 

los efectos de los acoplamientos durante la simulación del circuito. De esos cálculos, la 

herramienta sacará los parámetros S del circuito. 

Crear un mallado consiste en dos partes: 

• Definir los parámetros de la malla. 

• Precalcular la malla: podemos calcular la malla antes de la simulación con el objetivo 

de ver la malla, o de otra manera, se puede computar la malla como parte del proceso 

de simulación. En todos los casos, la malla es necesaria para realizar la simulación. 

4.1 Definición de la Malla 

Elegimos Momentum -> Mesh -> Setup, a fin de establecer los parámetros, que nos darán el 

control sobre el número de células que se crearán en el mallado. Cuantas más células se 

establezcan, mayor será la fiabilidad de la simulación, pero un número muy alto de células, 

podría ralentizar demasiado la simulación, proporcionando poca mejora respecto a un menor 

número. Se aconseja no establecer parámetros propios, y usar los parámetros por defecto 

para crear la malla. 

4.1.1 Definición de Parámetros para la Malla 

Se van a seguir los siguientes pasos para establecer parámetros globales del mallado del 

circuito: 

• Elegimos en el menú de la herramienta: Momentum -> Mesh -> Setup. 

• Nos aparecerá un cuadro de diálogo con los parámetros globales. 

• Introducimos la frecuencia del mallado en el campo “Mesh Frequency”, y 

seleccionamos las unidades. Se usará la longitud de onda para esta frecuencia, para 

determinar la densidad de la malla. En general, debemos establecer como frecuencia 

de mallado la mayor frecuencia que se vaya a simular. 

• Introducimos el número de células por longitud de onda en el campo “Number of Cells 

per Wavelength”. Este valor se usará también para determinar la densidad de la malla. 



• Pudiera ser que se tuvieran áreas curvas en el circuito que también hay que mallar. En 

el campo “Arc Facet Angle” introduciremos el número de grados que se incluirán en 

cada uno de los sectores. El máximo es 45 grados por sector. 

• Debemos habilitar “Edge Mesh” para añadir mallado a lo largo de los bordes de los 

objetos. Ya que la mayoría de las corrientes fluyen a lo largo de los bordes, el mallado 

de éstos puede mejorar la seguridad y la velocidad de la simulación. 

• Debemos habilitar “Transmission Line Mesh” para especificar el número de células a lo 

largo del ancho de una geometría. 

• Debemos habilitar “Layout Healing” para ignorar automáticamente pequeños 

artefactos no deseables o pequeños huecos en el layout. Esto puede mejorar la calidad 

del mallado. 

• Debemos habilitar “Thin layer overlap extraction” para extraer objetos para las 

siguientes situaciones: 

1. Dos objetos en diferentes capas solapándose. 

2. Objetos que están separados por una fina capa de sustrato. 

Si está habilitado, la geometría será modificada para producir un modelo más seguro 

para las regiones de solape. 

• Debemos habilitar “Mesh reduction” para obtener un mallado óptimo con el menor 

número de células y un mejor uso de la memoria y el tiempo de simulación. 

• Debemos habilitar “Horizontal side currents (thick conductors)” para activar corrientes 

en las caras horizontales en conductores espesos. 

• Si queremos volver a tener los parámetros por defecto, haremos click en “Reset”. 

• Hacemos click en “OK” para aceptar los parámetros globales de mallado. 

4.1.2 Precómputo del Mallado 

Elegimos Momentum -> Mesh -> Precompute para calcular la malla. Usando una frecuencia 

específica y algunos parámetros del mallado, se calculará un patrón de rectángulos y 

triángulos, que se aplicarán al circuito. Durante la simulación, se calcula la corriente superficial 

en cada célula, usando esta información para resolver los parámetros S de la estructura. 

Para el cómputo de la malla procedemos de la siguiente forma: 

• Elegimos Momentum -> Mesh -> Precompute… . 



• Se nos abrirá un cuadro de diálogo, donde debemos introducir la frecuencia que se 

quiere usar para el cómputo de la malla. La longitud de onda para esa frecuencia, en 

parte, determina el número de células en la malla. 

• Hacemos click en “OK” para empezar el cálculo de la malla. 

 

 

 

 

 

 

 

 

 



5 Simulación en Momentum 

El proceso de simulación combina la función de Green que se calculó en el cálculo del sustrato 

del circuito, más la información del mallado que fue calculado para el circuito, para resolver las 

corrientes del mismo. Usando estos cálculos, se calcularán los parámetros S para el circuito en 

cuestión. 

Antes de llevar a cabo una simulación debemos haber realizado los siguientes pasos: 

• Definición de un sustrato para el circuito. 

• El circuito debe tener al menos un puerto. 

• La malla será automáticamente calculada cuando simulamos. 

• Especificación de un plan de barrido en frecuencia. 

Si alguno de estos pasos no se lleva a cabo, “momentum” lanzará un error si se intenta realizar 

una simulación. 

5.1 Selección de la Matriz de Resolución 

Podemos seleccionar la matriz de resolución usada por “momentum” durante una simulación. 

Además del modo “auto-select mode”, “momentum” proporciona otras tres matrices de 

resolución: 

• “Direct Dense”. 

• “Iterative Dense”. 

• “Direct Compressed matrix solver”. 

Seleccionamos Momentum -> Simulation -> Setup para abrir la ventana de configuración de 

simulación. Esta ventana tiene dos pestañas disponibles. La pestaña “Options” permite 

seleccionar la matriz de resolución. 

 

5.2 Configuración de un Plan de Barrido en Frecuencia 

Se pueden especificar múltiples planes de barrido para una simulación. Para cada plan, se 

puede especificar una sola frecuencia en la que se pretende obtener una solución, o bien, un 

rango de frecuencias. Podemos seleccionar también uno, o varios tipos de barrido. Para 

configurar un plan de frecuencias seguimos los siguientes pasos: 

• Elegimos Momentum -> Simulation -> S-parameters. 

• Seleccionamos un tipo de barrido. Las elecciones posibles son: 



1. Adaptativo. 

2. Logarítmico. 

3. Lineal. 

4. Punto único. 

• Cuando hemos finalizado de configurar el plan, hacemos click en “Add to Frequency 

Plan List”. 

• Repetimos los pasos previos para introducir planes de frecuencia adicionales. 

Cuando finalizamos, hacemos click en “Apply”. 


